Acknowledgements

No single person can write a guide of this size and scope. I’d like to thank the other members of the QuickBooks Advanced Reporting team. Without you, this wouldn’t have been possible.

Copyright and trademarks

Copyright

© 2015 Intuit Inc. All rights reserved.

No part of this publication may be reproduced in any form or by any means, without prior written permission of Intuit Inc., with the following exceptions: Any person is hereby authorized to store documentation on a single computer or device for personal use only, and to print copies of documentation for personal use, provided that the documentation contains Intuit’s copyright notice.

Unauthorized reproduction is a violation of applicable laws. Intuit, the Intuit logo, QuickBooks, Quicken, and TurboTax, among others, are registered trademarks and/or registered service marks of Intuit Inc. Other parties’ marks are the property of their respective owners.

Various QuickBooks products and services are protected by pending patents and by one or more of the following U.S. Patents: 5134564, 5423033, 5649115, 5842185, 5903881 and 6446048.

Trademarks

Intuit, the Intuit logo, QuickBooks, Intuit Online Payroll, Quicken, QuickBase, TurboTax, EasyStep, and QuickZoom, among others, are registered trademarks and/or registered service marks of Intuit Inc. in the United States and other countries. Qlik® and QlikView® are registered trademarks of QlikTech International AB (“QlikTech”). Portions of these components are the copyrighted material of their respective authors.
<table>
<thead>
<tr>
<th>CHAPTER 1</th>
<th>Welcome to QuickBooks Advanced Reporting</th>
<th>2</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>About QuickBooks Advanced Reporting</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>QlikView® Resources</td>
<td>2</td>
</tr>
<tr>
<td>CHAPTER 2</td>
<td>Learn the basics</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Give a user access to Advanced Reporting</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>Open up a report template or create your own from scratch</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td>The Library</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Date</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>Find the help center</td>
<td>8</td>
</tr>
<tr>
<td>CHAPTER 3</td>
<td>Use objects</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td>Edit an object in a report</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td>Delete an object in a report</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td>Add a custom object</td>
<td>10</td>
</tr>
<tr>
<td>CHAPTER 4</td>
<td>Expressions and Dimensions</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>Overview</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td>Create a chart</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>Expressions we’ve created for you</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Here’s where you can find them</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>Understanding how to use them</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td>Set Analysis with variable example</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>List of pre-built expression syntax</td>
<td>20</td>
</tr>
<tr>
<td>CHAPTER 5</td>
<td>Master Calendar</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>What is a Master Calendar?</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>What if you wanted to see invoices, bills, or jobs based on their last payment date?</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>What if you wanted to see Sales Orders or Customers based on their last invoiced date?</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>What if you wanted to see Sales Orders based on their last shipped date?</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>What if you wanted to see transactions based on more than one date?</td>
<td>24</td>
</tr>
</tbody>
</table>
CHAPTER 1

Welcome to QuickBooks Advanced Reporting

Welcome to Intuit QuickBooks Advanced Reporting! We’re glad you’re here.

About QuickBooks Advanced Reporting

QuickBooks Advanced Reporting lets you use your QuickBooks data to create interactive reports and gain better insights into your business.

In this guide, we’ll walk you through some of the basic principles and features of Advanced Reporting. We know it’s a bit of a challenge, but there’s so much you can do with once you know how it generally works. Then, you can explore, experiment, and build reports on your own.

You can choose from some reports we’ve created or build your own report from scratch. Either way, you’re able to gain powerful insights into how your business runs

QlikView® Resources

QlikView®, a specialized reporting tool, powers QuickBooks Advanced Reporting. We’ve made it so QlikView® works within QuickBooks and uses your company data. Here are resources that you may find useful as you use QuickBooks Advanced Reporting, since the reporting portions (expression and dimension building, Properties window, etc) are QlikView®.

Please note that not all the Qlik® documentation will 100% apply to Advanced Reporting since we integrated it into QuickBooks. The Library in Advanced Reporting is an example of that. However, it will give you a great start in understanding how to build reports.


QlikView® Community: https://community.qlik.com/community/qlikview

Website: http://www.qlik.com/us/explore/products/qlikview


New to QlikView Community: https://community.qlik.com/community/qlikview/new-to-qlikview
QlikView® Resource Library: https://communityqlik.com/community/qlikview/resource-library
CHAPTER 2 Learn the basics

Give a user access to Advanced Reporting

Note that this is an “all or nothing” situation. If you give a user access, they will be able to use (and therefore, see) all your company data to create reports within Advanced Reporting.

For example, if you set the user up as a Sales Person who can only see Customer and Sales data and you give them access to Advanced Reporting, they can see everything in Advanced Reporting (but their permissions remain the same throughout the rest of QuickBooks).

1 Sign in as the Admin.
2 Under the Company menu, select Users > Set up Users and Roles.
3 Click the Role List tab.
4 Select the role to give Advanced Reporting access to.
5 Alternatively, you can click New to create a new role.
6 Click Edit to edit your selected role.
7 Under Area and Activities, select File > QuickBooks Advanced Reporting.
8 Under Activity Access Level, click Full.
9 Click OK

Open up a report template or create your own from scratch

1 Click List.
2 Click any report.
3 Reports with  are templates that load with your data.
4 Start From Scratch opens a blank report.
5 Open your saved reports from here.
6 Click Open.
The Library

The Library contains many pre-made objects that you can use to build your reports. We’ve already made charts, date ribbons, Current Selection boxes, and much more.

7 If you don’t see the Library (a menu on the left side of the screen) click Library at the top.

8 Double-click an object to add it to the report.

- List Box: helps you filter charts and tables you have on the report
- Tables/Charts: display your data so it’s easy to understand
- Date: includes multiple Date Ribbons and List Boxes to filter your reports by date (see Date)
- Text and Utility: These objects help you filter even further, search for something specific, or add titles and comments

9 Drag and drop to move the object around the report

Date

One section of the Library that is a bit more complicated than just adding objects is the Date section. It contains date ribbons and list boxes that you can use to filter chart objects with specific dimension. These date ribbons and list boxes are built around the concept that QlikView calls Master Calendars.

If you’re not familiar with the concept of Master Calendar and how it works, we suggested that you head over to the Master Calendar section of this User Guide to learn more.

The table below shows all the objects that appear in the Date section of the Library. It gives a description as well as the table or field that the object is made of.

Note: In order to see the data you expect, use these Date Library objects in tandem with other objects that contain the appropriate or “matching” table or field in the Dimension. See the “Other objects must have a Dimension that’s built using this Table/Field” column.

<table>
<thead>
<tr>
<th>Date Library Object</th>
<th>Description</th>
<th>Table/Field it’s made of</th>
<th>Other objects must have a Dimension that’s built with fields from this Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canonical</td>
<td>(Date Ribbon) Filter on date for multiple transaction dates.</td>
<td>CanonicalCalendar table</td>
<td>CanonicalCalendar table</td>
</tr>
<tr>
<td>Canonical (M/Y)</td>
<td>(List Box) Filter on date for multiple transaction dates. Shows last payment made on invoice by Month and Year</td>
<td>CanonicalCalendar.Month Year field</td>
<td>CanonicalCalendar table</td>
</tr>
<tr>
<td><strong>Canonical (Q/Y)</strong></td>
<td>(List Box) Filter on date for multiple transaction dates. Shows last payment made on invoice by Quarter and Year.</td>
<td>CanonicalCalendar.Quarter Year field</td>
<td>CanonicalCalendar table</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td><strong>Customer Last Invoiced</strong></td>
<td>(Date Ribbon) Filter on the date for the last Invoice created for a Customer:Job. Shows Month and Year.</td>
<td>CustomerLastInvoicedDatesCalendar.Month Year field</td>
<td>CustomerLastInvoicedDateCalendar table</td>
</tr>
<tr>
<td><strong>Customer Last Invoiced (M/Y)</strong></td>
<td>(List Box) Filter on the date for the last Invoice created for a Customer:Job. Shows Month and Year.</td>
<td>CustomerLastInvoicedDatesCalendar.Month Year field</td>
<td>CustomerLastInvoicedDateCalendar table</td>
</tr>
<tr>
<td><strong>Customer Last Invoiced (Q/Y)</strong></td>
<td>(Date Ribbon) Filter on the date for the last Invoice created for a Customer:Job. Shows Quarter and Year.</td>
<td>CustomerLastInvoicedDatesCalendar.Quarter Year field</td>
<td>CustomerLastInvoicedDateCalendar table</td>
</tr>
<tr>
<td><strong>Customer Last Payment</strong></td>
<td>(Date Ribbon) Filter on the date for last payment made on a Customer:Job.</td>
<td>CustomerLastPaymentDatesCalendar.Month Year field</td>
<td>CustomerLastPaymentDateCalendar table</td>
</tr>
<tr>
<td><strong>Customer Last Payment (M/Y)</strong></td>
<td>(List Box) Filter on the date for last payment made on a Customer:Job. Shows Month and Year</td>
<td>CustomerLastPaymentDatesCalendar.Month Year field</td>
<td>CustomerLastPaymentDateCalendar table</td>
</tr>
<tr>
<td><strong>Customer Last Payment (Q/Y)</strong></td>
<td>(List Box) Filter on the date for last payment made on a Customer:Job. Shows Quarter and Year.</td>
<td>CustomerLastPaymentDatesCalendar.Quarter Year field</td>
<td>CustomerLastPaymentDateCalendar table</td>
</tr>
<tr>
<td><strong>Transaction</strong></td>
<td>(Date Ribbon) Filter on all transactions.</td>
<td>Year, Month, Quarter fields</td>
<td>_TransactionDateCalendar table</td>
</tr>
<tr>
<td><strong>Transaction (M/Y)</strong></td>
<td>(List Box) Filter on all transactions. Shows Month and Year</td>
<td>Month Year field</td>
<td>_TransactionDateCalendar table</td>
</tr>
<tr>
<td><strong>Transaction (Q/Y)</strong></td>
<td>(List Box) Filter on all transactions. Shows Quarter Year field</td>
<td>Quarter Year field</td>
<td>_TransactionDateCalendar table</td>
</tr>
<tr>
<td>Transaction Last Invoiced</td>
<td>(Date Ribbon) Filter on the last invoice created from a Sales Order.</td>
<td>TransactionLastInvoiceDatesCalendar table</td>
<td>TransactionLastInvoicedDatesCalendar table</td>
</tr>
<tr>
<td>---------------------------</td>
<td>--------------------------------------------------</td>
<td>------------------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Transaction Last Invoiced (M/Y)</td>
<td>(List Box) Filter on the last invoice created from a Sales Order. Shows last invoiced for Month and Year.</td>
<td>TransactionLastInvoiceDatesCalendar.Month Year field</td>
<td>TransactionLastInvoicedDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Invoiced (Q/Y)</td>
<td>(List Box) Filter on the last invoice created from a Sales Order. Shows last invoiced for Quarter and Year.</td>
<td>TransactionLastInvoiceDatesCalendar.Quarter Year field</td>
<td>TransactionLastInvoicedDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Payment</td>
<td>(Date Ribbon) Filter on the last payment made on an invoice or bill.</td>
<td>TransactionLastPaymentDatesCalendar table</td>
<td>TransactionLastPaymentDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Payment (M/Y)</td>
<td>(List Box) Filter on the last payment made on an invoice or bill. Shows last payment for Month and Year</td>
<td>TransactionLastPaymentDatesCalendar.Month Year field</td>
<td>TransactionLastPaymentDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Payment (Q/Y)</td>
<td>(List Box) Filter on the last payment made on an invoice or bill. Shows last payment for Quarter and Year</td>
<td>TransactionLastPaymentDatesCalendar.Quarter Year field</td>
<td>TransactionLastPaymentDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Ship</td>
<td>(Date Ribbon) Filter on the last ship date for a Sales Order. This date is pulled from the Ship Date field on an invoice that’s associated with the Sales Order.</td>
<td>TransactionLastShipDatesCalendar table</td>
<td>TransactionLastShipDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Ship (M/Y)</td>
<td>(List Box) Filter on the last ship date for a Sales Order. This date is pulled from the Ship Date field on an invoice that’s associated with the Sales. Shows last invoiced for Month and</td>
<td>TransactionLastShipDatesCalendar.Month Year</td>
<td>TransactionLastShipDatesCalendar table</td>
</tr>
<tr>
<td>Transaction Last Ship (Q/Y)</td>
<td>(List Box) Filter on the last ship date for a Sales Order. This date is pulled from the Ship Date field on an invoice that's associated with the Sales Order. Shows last invoiced for Quarter and Year.</td>
<td>TransactionLastShipDatesCalendarQuarterYear</td>
<td>TransactionLastShipDatesCalendar table</td>
</tr>
</tbody>
</table>

Find the help center

1. Open QuickBooks Advanced Reporting

2. On the top right, click the (?).
CHAPTER 3 Use objects

Objects are the main items that you use in your report. They range from charts and tables to text and list boxes.

Edit an object in a report

1 Right-click on the object.
2 Select Properties.
3 Use the tabs at the top to edit the object

Delete an object in a report

1 Right-click anywhere in the blank space on the report. If you right-click on an object, you won't be able to see the correct option.
2 Click Properties.
3 Click the Objects tab
4
5 Select the object you want to delete. You can select more than one object using CTRL + click.
6  Click **Delete**.

7

8  Click **OK** to close the window.

**Add a custom object**

1  Right-click on any blank space in the report.

2  Select **New Sheet Object**.

3  Select the object you’d like to add.
CHAPTER 4 Expressions and Dimensions

Overview

Two key items to building your report are Expressions and Dimensions. You’ll use these to set up your data in tables, charts, and other objects in Advanced Reporting.

Expressions: Requires a calculation and is what gives bars and lines in charts their height. Think of this as what comes before the “per” in the statement “sales per country”. Sales is the expression.

Dimensions: How the data should be grouped. This think of this as what comes after the “per” in the statement “sales per country”. Country is the dimension.

For example, here are the Properties for the chat in the Customer List template. The dimension is Customer:Full Name, as seen under Used Dimensions.
One of the Expressions used is Balance. You can see what the syntax for Balance is if you look under Definition and click […] to open it.

So if we were to apply the same logic as “Sales per Country” here, we would say “Balance per Customer” or “The balance for my customer.”

Create a chart

1  Right-click any blank space in the report.

2  Select New Sheet Object.

3  Select Chart.
4 The chart building wizard starts with the title and type of chart you want.

5 Enter your chart title under the Show Title in Chart checkbox

6 Window title can be the same if you like. It just is what appears on the top bar of the chart window.

7 Select the type of chart you’d like to see your data in.
8 Click Next.

9 Select your Dimension. Usually, you’ll want to know more about your transactions so a good rule is to make choices from the Transaction table. We’ll use it in our example so you can see it.

10 From the Show Fields from Table menu, click Transactions.
11 From the Available Fields/Groups menu, select anything you'd like to see as the Dimension, or the word after “per” in our “Sales per Country” example. In this case, we’ll select Transactions.Customer Full Name.
12 Click Add.

13 Click Next.

14 Now it's time for Expressions. These are the words before the “per” in our Sales per Country example. Depending on what you want to see, you could make a lot of choices here. We'll start with “Active transactions per Customer.”

15 From the Table menu, select Transactions.

16 From the Field Menu, select Transactions. Active.

17 Click Paste.

18 Click OK to save.
19 Click Finish to see your chart or Next to do more with your chart.

Expressions we’ve created for you

We’ve created some expressions (called variables) that you can use in your reports. That way, you don’t have to write these Expressions yourself.

Here’s where you can find them

1 Right-click on an object.

2 Click Properties.

3 Open an Edit Expressions window.

- Click the Dimensions or Expressions tab
- Select any Dimension or Expression.
  - Dimensions: Click Edit.
  - Expressions: Double-click Expressions name or click […] under Definition.
Understanding how to use them

If you choose a variable from the list, you’ll see what data was used to put it together.

- vSet: Is a complete expression on its own and can be used in a set. Includes vExpr variables.
- vTxt: used as label, you can put it in a text area to turn it into something like a date, etc
- vExpr: meant to be used in set analysis as a part of an Expression.
  - vExprSales and vExprDayRangeFilter are used in the Item Sales Forecast report template (look under Expressions in Properties for the Sold last column). When you use something like vExprSales in a set, it already includes certain factors relating to your Sales. That way, you don’t have to build the expression each time.
Set Analysis with variable example

List of pre-built expression syntax

- **vExprCogs**: This variable can be used in set analysis when you want to do anything with the cost of goods sold for sales transactions. This is used in the Sales Profitability starter report to calculate the Total Cost of Products and Services.

- **vExprDayRangeFilter**: Use this expression as a modifier in set analysis to restrict the calculation between two dates.

- **vExprLast12MonthRolling**: Use this expression as modifier in set analysis to calculate amount or quantity for last 12 months. This is used in the Library object Sales - Top 10 items - last 12 months.

- **vExprMaxYear**: Use this expressions as a modifier in set analysis to make sure that you always have value for the max year of the current selection.
For example, if you use it sum({<$(vExprMaxYear)>}[Transactions.Amount]) and we select a particular year then the amount will be shown of that year. If you select more than two years, then the amount for the latest year shows.

- **vExprMonthRangeFilter**: This is same as vExprDayRangeFilter. It just works on monthly basis. In fact, vExprLast12MonthRolling is just a specific implementation of it.

- **vExprPreviousNMonths**: Use this as a modifier in set analysis. It produces a value for a particular month and takes one parameter. Use 0 for current month, 1 for previous month, and so on. You need to remember that these all work based on the current selection of dates. If you select Q2 of 2013, then the expression $vExprPreviousNMonths(0) points to the June 2013.

- **vExprPreviousNQuarters**: Same as vExprPreviousNMonths.

- **vExprPreviousNYears**: Same as vExprPreviousNMonths.

- **vExprSales**: Use this as modifier in set analysis to filter your data only for non-pending sales transactions.

- **vExprQuarterRangeFilter**: Same as vExprMonthRangeFilter.

- **vExprYearRangeFilter**: Same as vExprMonthRangeFilter.

- **vSetSalesIncome**: The sum of your sales income (as expressed in vExprSales).

- **vSetSoldQuantity**: The total quantity of your sales income (as expressed in vExprSales).

- **vTxtMonthYear**: This can be used to label your expressions. It goes hand in hand with vExprPreviousNMonths. If you use ${vExprPreviousNMonths(0)} in your set analysis, then you should use $(vTxtMonthYear(0)) as the label of this expression. If you want to have months in your dimension, then you can use [Month Year] in your dimension.

- **vTxtQuarterYear**: Same as vTxtMonthYear. In a dimension you can use [Quarter Year].

- **vTxtYear**: Same as vTxtMonthYear. In a dimension you can use [Year].
CHAPTER 5 Master Calendar

What is a Master Calendar?

A Master Calendar table is a dimensional table that links to dates in your company file data. It includes one record per date for the minimum and maximum dates in your company file.

The first Master Calendar that was built into Advanced Reporting was for transaction creation date for all transaction types.

To get a better picture of how this looks in a table, here’s an example:

Essentially what you’re seeing is a detailed presentation of Dates in the company file. You can use this to filter your reports and we’ve built it into the Library under Date > Transactions. This will show creation date for all transaction types.

Let’s walk through how to use dates like this in a simple report that shows transaction date for Month/Year:

1. Right-click anywhere in the white space.

2. Choose New Sheet Object > Chart.

3. Click the Pivot Table button.
4 Click Next.

5 From the Available Fields/Groups column, select **Month Year**.

6 Click **Add**.

7 From the Available Fields/Groups, select **Transactions.Txn Type**. You can narrow down the table to Transactions only by selecting **Transactions** from the **Show Fields from Table** drop-down.

8 Click **Add**.

9 Click **Next**.

10 In the Edit Expression window, type `sum()`.

11 Click between the parentheses so your cursor is in-between ( and )

12 Under the Field tab, select **Transactions** from the Table drop-down.

13 In the Field drop-down, select **Transactions.Amount With Sign**.

14 Click **Paste**.

*At this point, this chart just shows the use of Master Calendars and doesn’t reflect the right amount for any transactions. Use different expressions to show that. Here’s an example.*

15 Modify the expression to read: `sum([<Transactions.Header Or Line]=[Header] >) [Transactions.Amount With Sign]`

- **Transactions.Header Or Line**, with **Header** selected gives the transaction amount.

16 Click **OK**.

17 Click **Finish**.

So now you can see that you’ve bucketed these transactions based on month and year. There are totals based on all transactions according to the Month/Year that they were created.

**What if you wanted to see invoices, bills, or jobs based on their last payment date?**

The first Master Calendar used transaction date, which is equal to the date the transaction was created. We added more Master Calendars that use different sets of dates: the transaction payment date.

These Master Calendars use the following tables:

- **TransactionLastPaymentDatesCalendar**: uses the dates Invoices or Bills were last paid. You can use it to bucket your invoice or bills according to the date of the last payment.
• **CustomerLastPaymentDatesCalendar**: uses the dates that jobs were last paid. You can use it to bucket your Customer:Jobs according to the date of the last payment. See an example of this table is the Job Activities Over Time template.

**What if you wanted to see Sales Orders or Customers based on their last invoiced date?**

There are more Master Calendars that use different sets of dates: last invoiced dates.

These Master Calendars use the following tables:

- **TransactionLastInvoicedDatesCalendar**: uses dates based on Sales Orders. You can use it to bucket your Sales Orders according to the date of the latest invoice created from a Sales Order.
- **CustomerLastInvoicedDatesCalendar**: uses dates based on Customer:Jobs. You can use it to bucket your Customer:Jobs according to the date of their latest invoice.

**What if you wanted to see Sales Orders based on their last shipped date?**

There is another Master Calendar that uses a different set of dates: last shipped dates.

This Master Calendars use the following table:

- **TransactionLastShipDatesCalendar**: uses dates based on Sales Orders. You can use it to bucket your Sales Orders according to the last shipped dates.

**What if you wanted to see transactions based on more than one date?**

You should use the CanonicalDatesCalendar table.
Let’s look at a Canonical date example that you can find in the Library:

![Chart](chart.png)

The Dimension for this chart is CanonicalCalendar.Month Year. It’s used with the expressions:

- **Invoiced**: \( \text{sum}([\text{DateBridge.DateType}='\text{TransactionDate}', [\text{Transactions.Txn Type}='\text{Invoice}', [\text{Transactions.Header Or Line}='\text{Header}', \text{Transactions.Pending}=0]>][\text{Transactions.Amount With Sign}]) \)

- **Paid**: \( \text{sum}([\text{DateBridge.DateType}='\text{LastPaymentDate}', [\text{Transactions.Txn Type}='\text{Invoice}', \text{Transactions.Paid}=1], [\text{Transactions.Header Or Line}='\text{Header}']>][\text{Transactions.Amount With Sign}]) \)

Couple things to take note of in these expressions:

- **DateBridge table**, with the field pointing to LastPaymentDate. This table includes dates from other tables like Transactions and TransactionImportantDates. DateBridge table has a field called DateType that identifies the origin of the date. If you want to bucket your transactions according to more than one date, then use DateBridge in your expression the way it’s used in Library objects “Invoices vs Paid” and “Sales Order Created vs Sales Order Shipped.”.

- **Transactions.Header Or Line**, with Header selected gives the transaction amount.